Attention: Recently, security researchers have identified vulnerabilities in the TLS 1.1 encryption used by most websites to secure information online. Starting Friday, December 15th, 2017, Allegiance will require users to utilize a web browser with TLS 1.2 or later enabled. These advanced protocols offer increased security for your health information. Please update your browser to a version that supports TLS 1.2 or later or to the most current version; older browsers will be unable to access Allegiance websites.
Health Flex COBRA Starpoint